"Interpreter exited with code 139"

A forum for issues on macOS; the UNIX and Linux forums may have relevent posts

"Interpreter exited with code 139"

Postby haupz on Sat Mar 30, 2019 10:59 pm

Hello,

I have recently updated my macOS version to 10.14.4, and was prompted with the error message "Interpreter exited with code 139" when starting Dyalog 17. I do not know if the OS update is causing this. What does the error code mean, and what can I do about it?

Thanks,

Michael
haupz
 
Posts: 10
Joined: Mon Jul 02, 2018 7:28 am

Re: "Interpreter exited with code 139"

Postby AndyS|Dyalog on Sun Mar 31, 2019 9:01 am

Hello Michael

You are indeed correct .. it would appear that one of the underlying operating system functions has slightly changed behaviour between 10.14.3 and 10.14.4 and that is causing Dyalog APL to error on startup.

We believe that we have a fix for this issue which we expect we will be able to release tomorrow (2019-04-01) or the day after .. it all depends on how the final testing goes.

We will be issuing an email about this to all customers who hold a Dyalog APL for macOS licence - we will be offering all non-commercial and educational licence holders a free upgrade to 17.0.

If you've not already upgraded to macOS 10.14.4 we suggest you refrain from doing so until you have a new interpreter!

This is a macOS-only issue.
User avatar
AndyS|Dyalog
 
Posts: 216
Joined: Tue May 12, 2009 6:06 pm

Re: "Interpreter exited with code 139"

Postby DannyDer on Wed Apr 24, 2019 7:07 pm

Hello all

I bought today 24 april 2019 a new IMAC, and it arrived with version 10.14.4 Mojave installed as operation system.
When trying to start Dialog APL I also received a "interpreter ended with code 139".

Does any of you have an idea when or how I will be able to reuse APL again on my IMAC

Best greetings from Belgium

Danny Deraymaeker
dderaymaeker50@gmail.com
DannyDer
 
Posts: 1
Joined: Fri Feb 09, 2018 10:46 am

Re: "Interpreter exited with code 139"

Postby haupz on Thu Apr 25, 2019 4:28 am

Hello Danny,

what version of Dyalog APL do you have installed? Installing the update mentioned in a previous post in this thread fixed the issue for me.

Best,

Michael
haupz
 
Posts: 10
Joined: Mon Jul 02, 2018 7:28 am

Re: "Interpreter exited with code 139"

Postby AndyS|Dyalog on Thu Apr 25, 2019 8:26 am

Hi Denny

You will get an email from us in a while with details of how to get the latest 17.0 - the latest will run on 10.14.4.

We're a little concerned though that you did not get an email from us on 1st April about this as your address appears in the list that we sent the email to .. can you check to see whether the email ended up in your spam folder ..
User avatar
AndyS|Dyalog
 
Posts: 216
Joined: Tue May 12, 2009 6:06 pm


Return to macOS

Who is online

Users browsing this forum: No registered users and 1 guest