Dyalog APL does not run on Raspberry Pi Bookworm

For Raspberry Pi specific issues .. more general issues will appear in UNIX and Linux

Dyalog APL does not run on Raspberry Pi Bookworm

Postby AndyS|Dyalog on Mon Jan 08, 2024 1:32 pm

Our initial testing of Dyalog APL 17.1 and later running on Raspberry Pi OS Bookworm has revealed that various calls on Conga lead to syserrors and the similar.

We are investigating the cause of these errors and possible solutions, but for now we recommend that you do NOT upgrade any Raspberry Pi to Bookworm if you want to run Dyalog APL.
User avatar
AndyS|Dyalog
 
Posts: 260
Joined: Tue May 12, 2009 6:06 pm

Re: Dyalog APL does not run on Raspberry Pi Bookworm

Postby tomgarwin on Sun Mar 24, 2024 8:05 pm

Is this still true with Dyalog 19?
tomgarwin
 
Posts: 23
Joined: Sun Jul 23, 2017 11:37 am

Re: Dyalog APL does not run on Raspberry Pi Bookworm

Postby AndyS|Dyalog on Mon Mar 25, 2024 8:40 am

Memo to self: 20% of the job is in making the change, 80% is in telling the world of the change !

All of 17.1, 18.0, 18.2 and 19.0 will run on Bookworm provided that the revision number is 48479 or greater: all of the installation images for these versions have been suitably updated on packages.dyalog.com.

Just remember that all of them still require a 32-bit version of Raspberry Pi OS.
User avatar
AndyS|Dyalog
 
Posts: 260
Joined: Tue May 12, 2009 6:06 pm

Re: Dyalog APL does not run on Raspberry Pi Bookworm

Postby tomgarwin on Wed Mar 27, 2024 3:43 pm

Thanks!
tomgarwin
 
Posts: 23
Joined: Sun Jul 23, 2017 11:37 am


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest